summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYves Fischer <yvesf-git@xapek.org>2015-10-11 01:26:18 +0200
committerYves Fischer <yvesf-git@xapek.org>2015-10-11 02:41:56 +0200
commit5fbcb236f75454af5a474b45a74b02f69b09ca36 (patch)
tree3f9017af489b949ebb28ab5db2e9d38881543ffd
downloaddebian-ca-cern-gridca-5fbcb236f75454af5a474b45a74b02f69b09ca36.tar.gz
debian-ca-cern-gridca-5fbcb236f75454af5a474b45a74b02f69b09ca36.zip
copy of ca-cacertHEADmaster
-rw-r--r--debian/README.Debian4
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control23
-rw-r--r--debian/copyright27
-rw-r--r--debian/gbp.conf7
-rw-r--r--debian/install1
-rwxr-xr-xdebian/rules34
-rw-r--r--debian/source/format1
-rw-r--r--debian/triggers1
-rw-r--r--debian/upstream/sha512sums2
11 files changed, 106 insertions, 0 deletions
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 0000000..369d36b
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,4 @@
+System administrator may need to activate CAcert certificates using the
+following command:
+
+ sudo dpkg-reconfigure ca-certificates
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..d180733
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+ca-cern-gridca (2015.1011-1) unstable; urgency=low
+
+ * Initial version.
+
+ -- Yves Fischer <yvesf+debian@xapek.org> Sun, 11 Oct 2015 10:32:52 +1000
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..827d7e3
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,23 @@
+Source: ca-cern-gridca
+Section: misc
+Priority: optional
+Maintainer: Yves Fischer <yvesf+debian@xapek.org>
+Standards-Version: 3.9.6
+Build-Depends: debhelper (>= 9), gnutls-bin, openssl
+Build-Depends-Indep: wget
+Homepage: https://cafiles.cern.ch/cafiles/
+Vcs-Browser: https://www.xapek.org/git/yvesf/debian-ca-cern-gridca
+Vcs-Git: http://www.xapek.org/git/yvesf/debian-ca-cern-gridca.git
+
+Package: ca-cern-gridca
+Architecture: all
+Multi-Arch: foreign
+Depends: ${misc:Depends}, ca-certificates (>= 20140223)
+Enhances: ca-certificates
+Description: CERN Grid CA Certificates
+ This package provides the CERN Grid CA certificates.
+ Root certificates allow SSL-based applications to check for the
+ authenticity of certificates issued by the CERN GRID authority.
+ .
+ Please note that CERN Grid CA may or may not comply with RFC 3647
+ or similar standards.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..6b80a9e
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,27 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Source: https://cafiles.cern.ch/cafiles/
+
+Files: *
+Copyright: CERN, CH-1211 Geneva 23, Switzerland
+License: proprietary
+Comment: https://cafiles.cern.ch/cafiles/
+
+Files: debian/*
+Copyright: 2015 Dmitry Smirnov <onlyjob@debian.org>
+ 2015 Yves Fischer <yvesf+debian@xapek.org>
+License: GPL-3+
+
+
+License: GPL-3+
+ This program is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation, either version 3 of the License, or
+ (at your option) any later version.
+ ․
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ ․
+ The complete text of the GNU General Public License version 3
+ can be found in "/usr/share/common-licenses/GPL-3".
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644
index 0000000..6d49a53
--- /dev/null
+++ b/debian/gbp.conf
@@ -0,0 +1,7 @@
+
+[git-dch]
+id-length = 0
+
+[import-orig]
+pristine-tar = False
+merge = False
diff --git a/debian/install b/debian/install
new file mode 100644
index 0000000..16419f9
--- /dev/null
+++ b/debian/install
@@ -0,0 +1 @@
+*.crt /usr/share/ca-certificates/cern-gridca
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..914c07a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,34 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+%:
+ dh $@
+
+override_dh_auto_test:
+ #find . -maxdepth 1 -type f -name "*.crt" -exec openssl verify "{}" \;
+ find . -maxdepth 1 -type f -name "*.crt"
+ echo `pwd`
+ #certtool --verify --load-ca-certificate root.crt --infile 'CERN Grid Certification Authority.crt'
+ #certtool --verify --load-ca-certificate root.crt --infile 'CERN Root Certification Authority 2.crt'
+
+PKD = $(abspath $(dir $(MAKEFILE_LIST)))
+PKG = $(word 2,$(shell dpkg-parsechangelog -l$(PKD)/changelog | grep ^Source))
+VER ?= $(shell dpkg-parsechangelog -l$(PKD)/changelog | perl -ne 'print $$1 if m{^Version:\s*([\d\.+git]+)}')
+.PHONY: get-orig-source
+get-orig-source: cern-grid-ca.crt cern-root-ca-2.crt
+ sha512sum -c debian/upstream/sha512sums
+
+cern-grid-ca.crt:
+ wget -q --continue --timestamp \
+ "https://cafiles.cern.ch/cafiles/certificates/CERN%20Grid%20Certification%20Authority.crt" \
+ -O cern-grid-ca.crt
+
+# this one is shipped in 'der' not 'pem'
+cern-root-ca-2.crt:
+ wget -q --continue --timestamp \
+ "https://cafiles.cern.ch/cafiles/certificates/CERN%20Root%20Certification%20Authority%202.crt" \
+ -O - | openssl x509 -inform der > cern-root-ca-2.crt
+
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/triggers b/debian/triggers
new file mode 100644
index 0000000..2508bbf
--- /dev/null
+++ b/debian/triggers
@@ -0,0 +1 @@
+activate update-ca-certificates-fresh
diff --git a/debian/upstream/sha512sums b/debian/upstream/sha512sums
new file mode 100644
index 0000000..5d7d965
--- /dev/null
+++ b/debian/upstream/sha512sums
@@ -0,0 +1,2 @@
+15cf8db2a081aca31d149dbf6ffea47e11fb827376d41dcee1bbe0e9c316d512120c6f62206f3fd5963d15e48075a8e4a1348910d6bbb719aec71e2775e1c0eb cern-grid-ca.crt
+4fc126fa119ceade6e2d6a4d18a1d939bd4bf06066768f0aa8edeb8a7b78d40f0b62e44e702e8368b5078ebb2ef920a1c6de84ec631835d7e647f006058c99ba cern-root-ca-2.crt